Eclipse Errors on Mac OS X

“The eclipse executable launcher was unable to locate its companion shared library”

Try double-clicking directly on:
/Applications/eclipse/Eclipse.app/Contents/MacOS/eclipse
Hint: You may have to right-click on Eclipse.app and select "Show package contents."

If that doesn't work, check in:
/Applications/eclipse/Eclipse.app/Contents/MacOS
for a file named eclipse.ini

Check the file for file names or paths that no longer exist and change/delete them.